#1  
Old 23rd July 2012, 14:58
cnrbsc cnrbsc is offline
Junior Member
 
Join Date: Feb 2012
Posts: 1
Default Livestream iOS app streaming issue

When Livestream.com receives a live 640x480, 496kbps stream using MP4 AVC (h264) MAIN profile encoding (from Wirecast using FLME), viewing it on the Livestream 1.9.1 iOS app (on an iPhone 4s or iPad 2 via 3G or wifi) results in portions of the video where there is significant object or camera motion being rendered as jittery, flickering, blocky artifacts that tear the video apart until the motion stops and a keyframe is recv'd.

Changing to Baseline profile in the encoder corrects this and smooth, artifact-free video is recv'd.

Is this a known issue being worked on, since devices running iOS 4.x and up support Main profile MP4?
Reply With Quote
  #2  
Old 25th July 2012, 01:42
cseeman cseeman is offline
Livestream Community Help
 
Join Date: Nov 2008
Posts: 1,298
Default

For the time being use Baseline profile when streaming with Wirecast.
Although I'm not sure about Livestream's servers, Telestream found that Wowza 3 doesn't have this issue but Wowza 2 does. There's a fix they investigating in Wirecast which should work with all servers but, as you note, Baseline will work in the meantime.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump