#1  
Old 4th January 2011, 02:29
Skobb Skobb is offline
Junior Member
 
Join Date: Jan 2011
Posts: 4
Default Time delay while streaming.

I'm trying to stream some gameplay of Starcraft 2 to my friend so that I can go through things with him while I play.. Asides from the odd frame skipping which is bareable.. There's a good 30 secs delay on lower settings and 2 mins on higher quality settings..

I'm using Procaster and my connection speed is 500KB/s down - 100KB/s up.

Freemeter says I'm using something like 60KB/s up while I'm streaming..
Reply With Quote
  #2  
Old 4th January 2011, 11:43
mbaron's Avatar
mbaron mbaron is offline
Livestream Producer Support
 
Join Date: Dec 2010
Location: New York, NY
Posts: 1,726
Default

The problem you are experiencing is directly related to a lack of bandwidth. 100kbps upload speed is certainly not enough, we recommend at least 700kbps.
Reply With Quote
  #3  
Old 4th January 2011, 23:39
Skobb Skobb is offline
Junior Member
 
Join Date: Jan 2011
Posts: 4
Default

Hi, thanks for the reply.
I meant Kilobytes a second (kB/s), I think you're talking about Kilobits per second (kbps)?

Reply With Quote
  #4  
Old 6th January 2011, 03:16
Skobb Skobb is offline
Junior Member
 
Join Date: Jan 2011
Posts: 4
Default

;s no help?
Reply With Quote
  #5  
Old 6th January 2011, 12:28
benhomer benhomer is offline
Administrator
 
Join Date: Aug 2008
Posts: 570
Default

It seems likely that this delay is caused by geographical distance, for the most part we see good performance in Australia, but there may well be some latency issues because of your distance from the U.S. Can you try connecting to a U.S. server using speedtest instead of a server in Adelaide? If you see issues with this I would recommend getting in touch with your ISP.

-Ben
Livestream Support

Last edited by benhomer; 6th January 2011 at 12:33.
Reply With Quote
  #6  
Old 8th January 2011, 00:22
Skobb Skobb is offline
Junior Member
 
Join Date: Jan 2011
Posts: 4
Default



Is the latency an issue? 200-300ms I thought was pretty normal from Aus to US.

Also thought I'd mention that the delay slowly gets worse the longer I stream.

Thanks for the help so far
Reply With Quote
  #7  
Old 8th January 2011, 15:54
mbaron's Avatar
mbaron mbaron is offline
Livestream Producer Support
 
Join Date: Dec 2010
Location: New York, NY
Posts: 1,726
Default

That's sounds about right. The reason for the additional delay, the longer you stream is related to the buffer being built up so the video doesn't stutter.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump