#1  
Old 16th August 2011, 10:52
coryfrans coryfrans is offline
Livestream Procaster Support
 
Join Date: May 2009
Posts: 865
Default Procaster Mac v20.3 wishlist and bugs

Release notes:

The Livestream development team is proud to bring you Livestream Procaster for Mac version 20.2. We have been working over the last 6 months on making Livestream Procaster the most easy-to-use, high quality live streaming encoder in the world. We trust that you will enjoy this update. LEOPARD (10.5) IS NO LONGER SUPPORTED, MINIMUM REQUIRED VERSION IS NOW SNOW LEOPARD (10.6).



This page is also available on our user guide at http://www.livestream.com/userguide/...c_Version_20-2

New features in version 20.2

Major video and audio quality improvements with improved bit rate usage control
Perfect Audio/Video Synchronization live and on-demand. Previous versions had various issues with lipsync during long encoding sessions
Reduced CPU usage when streaming
Stream at higher bitrate over the same Internet connection: Improved the connection usage, so that you can utilize your connection more efficiently.
New easy to understand status message in the control bar with suggested solutions :
"Perfect Streaming" means that your stream is being sent to the Livestream server perfectly. No lag and no connection or CPU issues.
"CPU above 80% try closing other apps or stop lower quality" means that your CPU usage is above 80% and that you should close some other applications. When your CPU reaches 100% Procaster may stop broadcasting.
"Internet too slow for quality avoid shared connections or stop and lower quality" means that Procaster is not getting the full bandwidth it needs to stream and you should lower the quality of streaming in the main window.
"Lost internet connection. Attempting to reconnect. Local MP4 still recording." means that your internet connection fully dropped, and that Procaster is trying to reconnect. The local recording will always keep recording.
The CPU usage is also now shown in the control bar now.
New behaviours to better handle connection bandwidth fluctuation and drops :
Anti lag feature - When enabled (default), it will keep the delay between you and your viewer, up to a maximum of 10 seconds. The local MP4 file recording will always have all the frames, even if anti-lag kicks in
Continue to encode and record locally even when the internet connection is dropped : When your Internet connection suddenly drops, Procaster will continue recording and will go live again once you have regained connectivity. This can also be used to switch from one internet connection to another when experiencing an issue
HD Multi-bitrate Support on browsers and mobile devices:
You can now select qualities to stream at two, three or four bitrates at the same time (If you have enough resources - CPU/Memory/Bandwidth etc…).
The new Livestream Player now offers the ability for the user to select any of the qualities you are publishing from Livestream Procaster.
When viewing your live stream on iOS devices, the bitrate is automatically selected (adaptive) based on the viewers connection and the number of qualities you are encoding from Procaster.
Note : This only currently works with live streams, the recorded stream will be the main default stream (typically a 450-600Kbps stream)
Recording of all qualities to your “Movies” folder by default
The ability to select a different folder to save local recordings.
“Preview Only” channel option. This mode will only allow you to test your stream for 5 minutes
Improved detection on the removal and adding of audio devices
Perfect audio synchronization. The recorded files can be edited in Adobe Premiere and in Final Cut Pro.
Color Corrector Feature : Improve colors and brightness within Procaster.
Long recordings can be played back in Quicktime
Various Graphical User Interface fixes, such as:
Language fixes.
Support for multiple monitors.
Audio mixer can now be controlled with the arrow keys when you click the volume slider.
Improved Support for Certified Devices (capture card, devices and webcams) :

DeckLink SDI (SDI, HD-SDI)
DeckLink Duo (SDI, HD-SDI)
DeckLink Optical Fiber (SDI, HD-SDI)
DeckLink Studio (SD, HD-SDI, Component, Composite, S-video, HDMI)
DeckLink HD Extreme 3D (SD, HD-SDI, Component, Composite, S-video, HDMI)
Intensity Pro (Component, Composite, S-video, HDMI)


So post ALL your wishes and bugs in this thread and we will see what we can do for you!


If you have a bug, please post it in the following manner, so that we can help you as fast as we can.

-With what system you are using to stream (PC Intel at 2,4 ghz, 4 gb of ram...)
-At what quality you are trying to stream it (mobile, normal, medium + mobile, high + medium + mobile, HD + Medium + mobile, HD + high + medium + mobile, optimized game mode or custom (also include which custom settings))
-How are you trying to stream it (if this applies to you) with a capture card or any other capture device.
-If previous versions also has this problem
-A description of the problem you are experiencing

Last edited by RonaldH; 16th December 2011 at 18:43.
Reply With Quote
  #2  
Old 17th August 2011, 13:10
mnpublicradio mnpublicradio is offline
Junior Member
 
Join Date: Jan 2009
Posts: 3
Default Matrox MX02le device support

I am dying for our Matrox MX02LE capture device to work with Procaster. The sooner the better, we have lots of events coming up.

Thanks,
Erik
Reply With Quote
  #3  
Old 17th August 2011, 13:20
opencourt opencourt is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Default 20.2 crashy

We updated to 20.2 Procaster today and are running OS X 10.6.8 on a year-old Macbook Pro with 4GB RAM. 700kbps video quality over direct FireWire connection from HDV cam.

It's been crashy all morning with no error messages as well as "No Signal" interruptions. Will likely try to roll back this afternoon unless there's a fix.

Last edited by opencourt; 17th August 2011 at 13:23. Reason: more specific description of our settings
Reply With Quote
  #4  
Old 17th August 2011, 13:27
coryfrans coryfrans is offline
Livestream Procaster Support
 
Join Date: May 2009
Posts: 865
Default

Quote:
Originally Posted by opencourt View Post
We updated to 20.2 Procaster today and are running OS X 10.6.8 on a year-old Macbook Pro with 4GB RAM. 700kbps video quality over direct FireWire connection from HDV cam.

It's been crashy all morning with no error messages as well as "No Signal" interruptions. Will likely try to roll back this afternoon unless there's a fix.
Hello,

For the HDV camera you are using, is it set to HDV mode, or DV mode?
Reply With Quote
  #5  
Old 17th August 2011, 15:48
opencourt opencourt is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Default

It's in DV mode. We've changed nothing about our setup, which has generally worked for months, except for the ProCaster upgrade.

Last edited by opencourt; 17th August 2011 at 15:48. Reason: typo
Reply With Quote
  #6  
Old 17th August 2011, 16:12
Henry_live's Avatar
Henry_live Henry_live is offline
Livestream Producer Support
 
Join Date: Mar 2010
Location: New York
Posts: 640
Default

Quote:
Originally Posted by opencourt View Post
It's in DV mode. We've changed nothing about our setup, which has generally worked for months, except for the ProCaster upgrade.
opencourt,

Just ran a test with the latest version of procaster and I was not getting any "lost signal" errors. Please try uninstalling and reinstalling the latest version of Procaster and let us know if you continue to experience the problem.
__________________
-Henry
Reply With Quote
  #7  
Old 17th August 2011, 17:19
CGN7 CGN7 is offline
Junior Member
 
Join Date: Aug 2008
Posts: 2
Angry Same problem

I am having the same problem and I have tried reinstalling the program. Same thing happens. I am on a MAC if that helps. Are there certain setting that my MAC should be at? I had no trouble with Procaster until I installed the new version. HELP!!
Reply With Quote
  #8  
Old 17th August 2011, 17:24
RonaldH RonaldH is offline
Livestream Procaster Support
 
Join Date: Apr 2011
Posts: 401
Default

CGN7, could you go live, then after you get a lost signal, stop streaming, then go into preferences, then the video tab, and click save logs, send the logs saved to your desktop to procaster@livestream.com and we shall investigate.
Reply With Quote
  #9  
Old 17th August 2011, 18:01
CGN7 CGN7 is offline
Junior Member
 
Join Date: Aug 2008
Posts: 2
Default

Just sent off my logs.
Reply With Quote
  #10  
Old 18th August 2011, 12:43
opencourt opencourt is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Default

Quote:
Originally Posted by Henry_live View Post
opencourt,

Just ran a test with the latest version of procaster and I was not getting any "lost signal" errors. Please try uninstalling and reinstalling the latest version of Procaster and let us know if you continue to experience the problem.
Bug seems to remain. When livestreaming in Procaster 20.2 running OSX 10.6.8, we seem to consistently lose signal if an audio channel is removed via the audio mixer button on the bottom-bar Procaster pane.

Our current setup is connecting a MacBook Pro to an external camera via FireWire and we sometimes need to remove the internal microphone from the mix, because Procaster grabs both audio channels by default.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump