View Single Post
  #7  
Old 23rd January 2012, 14:31
CharReed CharReed is offline
Junior Member
 
Join Date: Jun 2009
Posts: 5
Default

Ah ha! Finally found the solution and I'm so happy to share it with everyone, since NO ONE's ever managed to post a decent answer!

I'll add everything I did… I'm not sure exactly which thing made it work, but if you do all these steps, hopefully it can be duplicated.

If Camtwist isn't showing up under your video sources, you need to:

• Change all of the browsers you use to 32-bit mode. See here: http://camtwiststudio.com/support/faq/

• Degrade your Flash Player. Flash 11 royally screws everything up, it's not Lion. I'm using v10.3.183.11. You'll still be able to watch Youtube videos, don't worry. Download it here: http://kb2.adobe.com/cps/142/tn_14266.html

• Degrade your Camtwist version. This may not be necessary, but I'm using v2.2 and it's working, so I'm not going to upgrade any time soon. I'm too stoked about it just working for now to potentially mess it up. Download here: http://camtwist.en.softonic.com/mac/download

• Use Raven. I don't know why Firefox and Safari still can't see Camtwist, but for some reason Raven can. Hey, I'll take it. Download Raven here (it's not a full fledged browser, but it's still pretty cool): http://raven.io/

• Once the proper copy of Camtwist is installed, follow all the rest of the instructions here (check and uncheck the options it says): http://camtwiststudio.com/support/faq/

• Also, under "Video Apps" in Camtwist prefs, drag and drop Raven, Safari and Firefox all to that application area. I have no idea if it helps, but I figure it can't hurt. I tested so many versions of Camtwist. I think 2.4 wouldn't allow drag and dropping of apps, but I downgraded to 1.7 and did that and it remembered the settings even after installing newer versions.

• Finally, you can test Camtwist, but it'll probably just show a default "CamTwist" screen, not your desktop. So…

• RESTART. After restart, open Camtwist, set it up, open Raven, go to Livestream or Ustream and it should be in the drop down menu under Video Sources. Select, and wah-lah, it works!

I have no idea why it's only working in Raven or why Flash 11 is screwing it up or even if the latest version of Camtwist works with this process, but I jury rigged it to work by doing all these things. Hopefully this post can help someone else who's been losing their mind over this problem as well, since no one else ever seems to have an answer. Crossposting this so hopefully more people will get a solution that works for them.
Reply With Quote